Skip to main content
pdf?stylesheet=default
Blackboard Help

Minimum System Requirements

Minimum System Requirements

Please refer to the following Knowledge Base articles for the minimum system requirements for the Blackboard Collaborate server, ELM and Blackboard Collaborate clients:

Blackboard Collaborate server:

http://support.blackboardcollaborate.com/ics/support/default.asp?deptID=8336&task=knowledge&questionID=2845

ELM:

http://support.blackboardcollaborate.com/ics/support/default.asp?deptID=8336&task=knowledge&questionID=2844

Blackboard Collaborate clients:

http://support.blackboardcollaborate.com/ics/support/default.asp?deptID=8336&task=knowledge&questionID=2890