Skip to main content
Blackboard Help

Internet/Edline Reports

Edline allows for easy uploading of student reports directly from Easy Grade Pro, making it the best way to regularly upload reports. Once you have customized the report to display the information you want, instead of printing the report you will send the report to Edline for students and parents to view online.

How to Upload Reports to Edline

  • Choose File > Internet/Edline from the File menu or click the Internet tool File:en-us/Edline/050_Gradebooks/020_Easy_Grade_Pro_(EGP)/120_Internet//Edline_Reports/InternetTool.jpg to open the Internet/Edline window.
  • From the Action menu, select Upload Reports to Edline.
  • From the for menu, select the classes. If you select the last item, be sure to select one or more classes from the list below the List tab.
  • Select the Options tab and set the Edline Upload Reports Options:
    • The Edline Report/Folder Name is the name of the folder to hold the reports on Edline. This name will be visible to viewers. You can use one or more folders for different reports such as Quarter 1 Reports, Quarter 2 Reports, Final Reports, Missing Work Reports, or November Grades. If you want to upload reports that replace older reports for your student, use the same name for the folder. If you want to upload reports that do not replace older reports, use a new folder name.
    • If you turn on the Include Multiple Classes (in each report) option, then you will need to enter an Edline ClassID into the Edline (multi-class) ClassID field. This will be the class page on which the report will be viewed by parents. You must also enter an Edline (multi-class) Class Title (Ms. Demo’s 6th Grade).
  • Set the remaining report options under the Options tab as desired.
  • Click the Upload button. Easy Grade Pro will open your web browser to the Edline server and send the reports. You may be prompted to enter your Edline screen name and password.
  • You will get a status report telling you the number of reports sent. It will tell you the number of reports added (i.e. sent for the first time), the number updated (i.e. that overwrote an existing report for the student), and the number that had errors. Below this you will see an explanation for each error that occurred. You should fix any errors and then re-send reports for the students who had errors.

How to View Posted Reports

  • On Edline, select the class whose report you want to see.
    The report folder (name assigned when you posted the report), will be found in the Contents box on the class home page. Click the folder name to open it.
  • You will see the name of each student for whom this report was sent from Easy Grade Pro. Click the student’s name to see the report. The report will look the same as it did in the Internet/Edline window in Easy Grade Pro.

When students visit the class home page and click on the report, they will only see their own reports; they will not see other students’ reports. Likewise, when parents click on the report, they will only see reports for their children.