Skip to main content
Blackboard Help

Upgrade Learn

If you are a Managed Hosting customer, this topic doesn't apply to you.

This section covers the steps for updating a previous installation of Blackboard Learn for Unix or Windows environments.

Starting with the April 2014 release, Blackboard Learn 9.1 is based on an Apache™ Tomcat-only architecture, which no longer requires the installation of an HTTPD service (Apache or IIS). As a result, this release requires specific operating system configuration changes prior to installation that were not necessary for previous versions of Learn. Please read the release notes and the installation topics completely before proceeding. Pay particular attention to required port and web server changes.

If using Portfolios and upgrading Blackboard Learn with an Oracle database, there is a risk on upgrading to the new Portfolios that will leave partially migrated Portfolios and possible duplicates of partially migrated portfolios. Only personal Portfolios with no name are affected. To mitigate the risk of partially migrated portfolios prior to running the Learn upgrade, you must execute the following SQL on your Oracle database: update pflio set title='.' where title is null.

Prepare for the upgrade

To prepare for your upgrade, read the release notes. You may also want to review Understanding the Changes. These topics contain important information such as what's new and changed, prerequisites for the upgrade, and instructions for running the Installer.

Finally, as preparation, make certain you have backed up your current application server and database. See Back Up and Recovery for instructions for backup and recovery of Learn and the supporting database.

To learn more about the methodologies for determining the Dell or Sun hardware needed to support Blackboard Learn, see Hardware Sizing.

Upgrade checklist

  1. For self-hosted installations, be sure your server hardware and software will support Learn 9.1.
  2. If you have made customizations to your login page, system themes, roles, course templates, or building block availability, record all of the customizations and back up customized files.
  3. Review all security measures and policies to be sure your system has the best protection and meets any new standards or security changes.
  4. Prepare your end users, faculty, staff, and students using the Communication and Adoption Toolkit to inform them about new features and functions.
  5. Review other relevant institutional practices and policies.
  6. If you have an Outcomes Assessment license, read Change Management and Updates to Outcomes Assessment before upgrading Blackboard Learn.

There is an impact on your assessment data in Learn 9.1 2014 and later. It is important to review the change management documentation and plan an upgrade pathway to the new Outcomes Assessment building block before upgrading to Learn 9.1 2014 and later.

For a thorough checklist of tasks after an upgrade, see Post Install and Upgrade Tasks and Test the Learn Environment Post Install or Upgrade.

Perform the upgrade

Refer to our step-by-step guide to upgrade your instance of Blackboard Learn 9.1.

For steps to perform a fresh install of Blackboard Learn 9.1, see Install Learn.

After the upgrade

Starting with the April 2014 release, Blackboard Learn requires TLS. TLS serves to guarantee the authenticity of your server. Self-signed certificates such as the one installed by the Blackboard Learn installer do not provide an TLS required chain of trust. Chain of trust provides the Certificate Authority which guarantees the authenticity of the certificate identifying the server. For this reason, a non-commercial self-signed certificate is not suitable for connecting to SafeAssign or Blackboard Cloud Services, which require a commercial Certificate Authority.

More on configuring Blackboard Learn to use TLS

More on improving the performance of Blackboard Learn

More on the back-end administration of Blackboard Learn, including how to integrate with an existing authentication system