Skip to main content
Blackboard Help

Why can't I get Mobile Learn on my device?

Mobile Learn is supported on Android 2.3 and higher and on iOS 6 and higher. If you use older software versions, you will not be able to update to Mobile Learn 4.x. We've made this decision given that we see an overwhelming percentage of our users on these or later versions of iOS and Android.

Need Help?

Email Support

@BbMobileSupport on Twitter